CAElinux 2020: Grub installation fails

More
1 month 3 weeks ago - 1 month 3 weeks ago #10069 by Gary
Hello.  I am trying to install CAElinux on an older Dell Latitude E5500 (pre-EFI) system.  I would like to use LUKS and LVM; and, have been following the directions listed here - excluding (or correcting for) the lack of nvme and "DEVP" devices. I am trying to avoid inserting a USB drive at every boot..

Everything goes well up until the installation media attempts to install GRUB.  The GRUB install fails and subsequently halts the entire CAElinux install.  I've attempted to correct the problem by installing/running boot-repair from the LTS prior to reboot.  However, it does not offer an automated repair option because the GRUB bootloader has not been loaded to /dev/sdb (no .cfg or .conf files exist, meaning grub-update is not possible either).

I've tried "grub-install --force /dev/sdb" but it fails stating that it "cannot find the canonical path to '/cow'" (paraphrase).

I am assuming that the issue with Ubiquity and encrypted /home directories that is mentioned here has been corrected with respect to LUKS in more recent releases of Ubuntu (and hopefully Xubuntu 18.04) LTS.  However, I could be wrong.

Boot-repair does give me a BootInfo summary, which I've uploaded to pastebin here .  Of note is line 24: "=> No boot loader is installed in the MBR of /dev/sdb."

I'd like to have both MBR and EFI capability should I wish to upgrade to a newer system.  LVM is just handy, in general.

More importantly, I am hoping to use this system to create patent drawings, which is why I am really, really hoping that I can use LUKS encryption.

It might also be worth mention that the loop "while [ ! -d /target/etc/default/grub.d ]; do sleep 1; done; echo "GRUB_ENABLE_CRYPTODISK=y" > /target/etc/default/grub.d/local.cfg" from the first link provided DOES NOT complete; at which point the installation cannot be continued without a bootloader being installed nor can it be cancelled.

I am able to switch back to the Terminal window from the installer and mount the /dev/mapper/CAElinux----vg-root target (as directed in the first link, above).  However, it seems pointless to continue with the rest of the post-installation steps afterward.

Any suggestions/solutions will be very much appreciated! I'm a bit tired of running DBAN :)

Cheers!
Last edit: 1 month 3 weeks ago by Gary. Reason: Added boot USB avoidance.

Please Log in or Create an account to join the conversation.

More
1 month 3 weeks ago #10070 by Gary
Replied by Gary on topic CAElinux 2020: Grub installation fails
I tried running the installation another time with erase and install, encryption, and LVM options selected. It worked as desired - the bootloader is installed to the hdd.

The first 3 times I tried these settings, it rendered the LTS unbootable, and the hdd OS would not load (stuck on flashing cursor after Dell logo on reboot) unless the same USB drive was inserted (no bootable Ventoy nor CAE installation on media).

I'm not sure what happened the first few attempts (I'm almost certain that the correct disk was selected each time), but apparently this isn't an issue.

"Issue" is resolved. Whatever that issue might have been (eg. a user error on my part?).

Please Log in or Create an account to join the conversation.

Moderators: catux
Time to create page: 0.120 seconds
Powered by Kunena Forum