CA 10.7 parallel Debian7 - make ptscotch

More
9 years 1 month ago #6650 by RichardS
Replied by RichardS on topic Re: CA 10.7 parallel Debian7 - make ptscotch
Hallo Markus,
klar kannst du die als Vorlage nutzen. Möglicherweise müssen jedoch einige Pfade, bzw die MATH libraries angepasst werden.
Möglicherweise ist dies auch ein grund dafür, warum deine STA10.7 nicht funktioniert.
Mehr kann ich dir leider nicht helfen.

Gruß,
Richard

SimScale - Engineering Simulation in your browser!

Please Log in or Create an account to join the conversation.

  • MGolbs
  • MGolbs's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
More
9 years 1 month ago - 9 years 1 month ago #6651 by MGolbs
Hallo Richard,

danke für die Rückmeldung. Ich werde mal diese PAR Config versuchen anzupassen.

Könnte es Probleme geben, weil ich gfortran_4.4.5-1_amd64.deb verwende?


Gruß und Dank Markus


Hallo,

auch mit der config.txt hat sich nichts verbessert.


File Attachment:

File Name: 2012-12-24...t.tar.gz
File Size:41 KB



Gruß Markus

Dem Überflüssigen nachlaufen, heißt das Wesentliche verpassen.
Jules Saliège
Attachments:
Last edit: 9 years 1 month ago by MGolbs.

Please Log in or Create an account to join the conversation.

  • MGolbs
  • MGolbs's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
More
8 years 6 months ago #7018 by MGolbs
Hallo,

habe bei der parallelen Installation die Erfahrung gemacht, dass der letzte make Befehl für aster parallele unter Debian7 kurz vor Ende scheitert, beim Ubuntu 12.04 mit identischen Vorherablauf (jeweils ohne Fehler) funktioniert. Das Anlegen der "Elemente" unter Debian scheint irgend wie nicht stattzufinden...


Gruß und Dank Markus

Dem Überflüssigen nachlaufen, heißt das Wesentliche verpassen.
Jules Saliège

Please Log in or Create an account to join the conversation.

More
8 years 6 months ago #7019 by RichardS
Replied by RichardS on topic Re: CA 10.7 parallel Debian7 - make ptscotch
Hallo Markus,
das Problem mit dem Elementkatalog ist bekannt und liegt höchstwahrscheinlich am Compiler.
Eine Lösung findest du zum Beispile hier: www.code-aster.org/forum2/viewtopic.php?id=18751

Gruß,
Richard

SimScale - Engineering Simulation in your browser!

Please Log in or Create an account to join the conversation.

  • MGolbs
  • MGolbs's Avatar Topic Author
  • Offline
  • Platinum Member
  • Platinum Member
More
8 years 6 months ago - 8 years 6 months ago #7020 by MGolbs
Hallo Richard,

danke für die Info. Dann sollte ich es auch unter Debian 7 zum laufen bringen?

Gruß und Dank Markus

Diese Anpassung hat bei mir leider keine Effekte gezeigt.

compilation of elements with /opt/aster/PAR10.8/asteru [FAILED]
Exit code : 4

Version parallèle de Code_aster compilée avec MPI
Exécution sur le processeur de nom debian7-1861 de rang 0
Nombre de processeurs utilisés 1


nach dem Abbruch von

../bin/as_run --vers=PAR10.8 --make


wird unter /tmp sofort alles gelöscht.

ein

To re-run compilation manually :
cd /tmp/hagolbsm-debian7-1861-build.8217/global/global
mpirun -np 1 --hostfile /opt/aster/etc/codeaster/mpi_hostfile /tmp/hagolbsm-debian7-1861-build.8217/global/global/mpi_script.sh


Ist dann gar nicht möglich. Werde dann also auf 12.04 für CA umsteigen.

Gruß und Dank Markus

Dem Überflüssigen nachlaufen, heißt das Wesentliche verpassen.
Jules Saliège
Last edit: 8 years 6 months ago by MGolbs.

Please Log in or Create an account to join the conversation.

Moderators: catux
Time to create page: 0.122 seconds
Powered by Kunena Forum