Erreur au démarrage de ASTK

  • Michael
  • Topic Author
  • Visitor
  • Visitor
15 years 1 week ago #367 by Michael
Erreur au démarrage de ASTK was created by Michael
Bonjour, je viens de télécharger CAELinux beta 2 et j'en suis à mes premiers jours sur l'environnement de Linux. Tous les programmes fonctionnent (à première vue) sauf ASTK. Lorsque je l'ouvre, il y a une erreur qui se produit lors de sont initialisation. Une petite fenêtre s'ouvre et il est écrit: Error: extra characters after close-cote. Lorsque je clique sur détail:
extra characters after close-quote
extra characters after close-quote
while executing
\"ashare::attend couldn't execute \"rsh\": no such file or directory /tmp/astk_root/.file_rexec_outerr_-1689104654 .fen_about\"
(\"after\" script)

Merci à l'avance pour votre aide

Michaël

Please Log in or Create an account to join the conversation.

  • admini
  • Topic Author
  • Visitor
  • Visitor
15 years 1 week ago #368 by admini
Replied by admini on topic Re:Erreur au démarrage de ASTK
Cette erreur se produit généralement lorsque votre système est configuré avec un adressage dynamique DHCP, ce qui peut changer votre nom d'hote par rapport à la configuration par défaut (localhost) et laisse penser à ASTK que le serveur de calcul sur lequel vous lancez le job est distant (et donc utilise RSH!!).

Essayez de déconnecter votre réseau pour faire un test et de bien vérifier que votre machine est nommée localhost (PcLinuxOs Control Center, configuration réseau).

Je n'ai malheureusement pas encore trouvé de parade pour faire fonctionner ASTK avec un PC configuré en adressage dynamique DHCP... Donc si c'est bien la cause de votre soucis, il faut donc désaciver la configuration réseau automatique et entrer les paramètres statiques (+ nom d'hote = localhost ).

Il ne s'agit là que d'une piste plausible pour résoudre le problème, cependant, je n'ai malheureusement pas l'infrastructure nécessaire pour tester ce genre de cas, désolé.

Please Log in or Create an account to join the conversation.

  • Michaël
  • Topic Author
  • Visitor
  • Visitor
15 years 1 week ago #373 by Michaël
Replied by Michaël on topic Re:Erreur au démarrage de ASTK
Ce que vous m'avez dit à l'air de fonctionner mais j'aurais encore besoin de votre.

J'ai déconnecté ma connection à partir du panneau de configuration; j'ai mis la DHCP sur none. Par la suite, je suis aller configurer le DSN. Où il est écrit host name, j'ai écrit localhost et j'ai laissé les trois autres espaces en dessous vides.

Maintenant, quand j'ouvre ASTK, il dit qu'il ne trouve pas le localhost dans le domaine. J'imagine que je ne l'ai pas bien configurer.

Est-ce que la démarche que j'ai fait est bonne ou il y a quelque chose que je n'ai pas fait correctement ou il y a d'autre chose à faire de plus.

Merci

Please Log in or Create an account to join the conversation.

More
15 years 1 week ago #381 by Joël Cugnoni
Replied by Joël Cugnoni on topic Re:Erreur au démarrage de ASTK
Ok, voici la démarche détaillée (pas testée mais devrait aider...):

La première tentative est d'utiliser DHCP mais sans redéfinir le nom de la machine:
1) PCLinuxOs Control Center->Networking : Create new network interface...
2) Sélectionnez LAN connection puis votre carte réseau
3) ensuite dans Configuration, choisissez DHCP
4) déselect. Assign Host name from DHCP
et entrez localhost comme nom de machine (dans cette fenêtre et les deux suivantes)


Deuxième option: config manuelle

essayez de repérer les adresses IP de votre machine configurée en DHCP ainsi que les DNS et gateway: dans une console, tapez:
ifconfig
puis
cat /etc/resolv.conf
et
route

Finalement :
1) PCLinuxOs Control Center->Networking : Create new network interface...
2) Sélectionnez LAN connection puis votre carte réseau
3) ensuite dans Configuration, choisissez MANUAL
4) entrez localhost comme nom de machine puis les IP trouvées auparavant (pour info, chez moi, sous VMWare, j'ai Search domain: localdomain).
5) entrez localhost comme nom de machine (dans cette fenêtre et les deux suivantes)


Voilà, si le problème persiste, essayez de poster ici les réponses des commandes ifconfig, route, cat /etc/resolv.conf

Bonne suite.

PS: vous pouvez aussi essayer d'installer RSH etc.. mais la configuration est assez complexe (fichiers de configs divers à éditer). Surtout que dans votre cas, ASTK ne devrait pas avoir besoin d'utiliser des commandes \"Remote\".

Joël Cugnoni - a.k.a admin
www.caelinux.com

Please Log in or Create an account to join the conversation.

  • Michael Pagé
  • Topic Author
  • Visitor
  • Visitor
15 years 1 week ago #382 by Michael Pagé
Replied by Michael Pagé on topic Re:Erreur au démarrage de ASTK
J'ai essayé tout ce que vous m'avez dit mais ça ne marche pas encore. Cependant, on semble être dans la bonne voie. Les erreurs au démarrage n'arrive plus mais, lorsque je fait run, le fichier reste en mode \"pend\". Seul un fichier .mess est créé mais il est vide.

Voici mon ifconfig:

eth0 Link encap:Ethernet HWaddr 00:0C:6E:6B:C5:40
inet addr:24.201.86.202 Bcast:255.255.255.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:22252 errors:0 dropped:0 overruns:0 frame:0
TX packets:1959 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3232088 (3.0 Mb) TX bytes:229851 (224.4 Kb)
Interrupt:5 Base address:0x2000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:172 errors:0 dropped:0 overruns:0 frame:0
TX packets:172 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9253 (9.0 Kb) TX bytes:9253 (9.0 Kb)


Voici le route:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
24.201.86.0 * 255.255.255.0 U 10 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default modemcable001.8 0.0.0.0 UG 10 0 0 eth0

et voici cat /etc/resolv.conf :

nameserver 24.200.241.37
nameserver 24.201.245.77
nameserver 24.200.243.189

Merci beaucoup pour votre aide

Please Log in or Create an account to join the conversation.

  • admin
  • Topic Author
  • Visitor
  • Visitor
15 years 1 week ago #384 by admin
Replied by admin on topic Re:Erreur au démarrage de ASTK
Bon... je ne vois toujours pas la cause exacte du problème...

Maintenant, on va voir ce que l'on peut changer au niveau de la configuration d'ASTK:
- lorsque vous ouvrez ASTK, avez-vous un message \"INFO Domain name not defined for localhost...\"? Sur mes installations, j'ai toujours eu ce message car je ne définis jamais de domaine pour mes machines (petit réseau).
- ensuite dans Configuration->interface: 1) vérifiez que DHCP/VPN mode n'est PAS activé, et notez le ClientMachineName et le DomainName
- dans Configuration->Servers, assurez vous que le nom du serveur est bien ClientMachineName.DomainName ou seulement ClientMachineName si DomainName est vide.
- Faites un REFRESH Now pour s'assurer que vous pouvez communiquer avec le serveur.

J'ai essayé de reproduire votre problème sous VMWare, mais rien n'y fait... en DHCP avec tout par défaut, tout fonctionne... désolé.

Please Log in or Create an account to join the conversation.

Moderators: catux
Time to create page: 0.138 seconds
Powered by Kunena Forum