Re: Calculix lib error

  • SebastianR
  • SebastianR's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
More
8 years 2 months ago #6388 by SebastianR
Re: Calculix lib error was created by SebastianR
Hello.

If you want to use the current version Calculix on a installed version of CAELinux, I'll recommend you to try to compile it from source, by this way all libs are correctly configurated to work on your system and even more you can compiled to work on multi core function.

If you still want to use the regular executable file from the web page you can try to do a symbolic link like this: "sudo ln-s / usr/lib/x86_64-linux-gnulibgfortran.so.3 / usr/lib/libgfortran.so.2" . Changing "/ usr/lib/x86_64-linux-gnu" for the address where libgfortran.so3 is installed.

You can find out how to do both on Libre Mechanics web page : How To Install CalculiX 2.4 multi-thread under Ubuntu 11.04 and later.

But as I said, unless you work from a live session, taking the time for compiling it, is the best choice.

Good luck.


Jhoan Sebastian Rodriguez
Mechanical Engineer
www.libremechanics.com/

Please Log in or Create an account to join the conversation.

Moderators: catux
Time to create page: 0.105 seconds
Powered by Kunena Forum