CAELinux 2018 finally released.

  • Joël Cugnoni
  • Topic Author
  • Offline
  • Administrator
  • Administrator
10 months 2 weeks ago - 10 months 2 weeks ago #9339 by Joël Cugnoni
CAELinux 2018 finally released. was created by Joël Cugnoni
It is my pleasure to announce a new release of CAELinux: CAELinux 2018.

CAELinux 2018 is the final release that stems from the beta version CAELinux 2017 that I did not manage to complete before.

CAELinux 2018 is still based on Xubuntu 16.04.5 with all recent patches, and contains all the familiar software that you expect from CAELinux: Salome-Meca 2018, Code-Aster 13.4 MPI, Code-Saturne 5.04, OpenFOAM 4 with HelyxOS GUI, Calculix 2.13 with CalculixLauncher GUI, Freecad 0.17, Elmer, GMSH, and a many more.

You will find as well all the custom GUI WIzards to prepare simulation projects for Aster, OpenFOAM and Code-Saturne.

CAELinux also includes all you need for programming: Python / Scipy with Spyder, C/C++/Fortran with Geany and GNU compilers, and a plethora of mathematical modeling tools such as Octave, Scilab, Maxima, R for example.

Finally, you will also find all you need for microcontrollers, electronic design and prototyping with Arduino, Kicad, and Flatcam for isolation milling of PCBs as well as Camotics, Pycam & Slic3r and other G-Code preprocessors for CNC prototyping.

The new ISO image is available for download on http://caelinux.sf.net

To install it on USB drive, I would recommend using http://rufus.ieRUFUS on Windows as it always worked for me during testing! Or just burn it to DVD as usual.

As always, you can safely run regular updates but please DO NOT UPGRADE your installation to 18.04! I have not tested it but it will surely create issues with many of the custom software installed.

For more details see the Getting Started instructions HERE

Finally a note on Virtual Machines: CAELinux works perfectly in both VirtualBox and VMWare but to use SalomeMeca and more specifically it's Paraviz postprocessing module, you will need to have a proper hardware 3D acceleration. Unfortunatelly VirtualBox does not offer a sufficiently capable version of OpenGL acceleration and this module does not work properly in VBOX. However, VMWare Player works flawlessly and provides a better graphics performance. So my advice would be to use VMWare Player for virtualization of CAELinux 2018.

Overall, despite the long wait, I hope that you will like it !

Joël
Last edit: 10 months 2 weeks ago by Joël Cugnoni.
The following user(s) said Thank You: Claus, Oleg V. Melnichuk, Giovanni Malagnino, ing.nicola.dettole, Helio C

Please Log in or Create an account to join the conversation.

More
10 months 3 days ago #9343 by Hui Cheng
Replied by Hui Cheng on topic CAELinux 2018 finally released.
Great news!

Please Log in or Create an account to join the conversation.

More
8 months 2 weeks ago #9414 by Leo
Replied by Leo on topic CAELinux 2018 finally released.
Thank you.
New updated version of CalculiX Launcher is here
sourceforge.net/projects/calculixforwin/files/03.3/

What's New (CL.33)?
1. CalculiX Launcher v.33 has latest version of CalculiX (2.15) with help files and verification examples.
2. New version of CCX Editor with source code (it has independent 3d viewer with list of groups and some additional functions, based on 'send' card of CalculiX CGX). If you want to help in development or compile binaries for other system, such as Mac – please use Lazarus Free Pascal (FPC 3.0).
3. As usual, we provide both Linux 32/64 bit full versions of Launcher, for your convenience when using VirtualBox in Windows or Mac. Native version of Launcher for Windows has limited capabilities due to some unsolved problems).
4. This package has 3 versions of CCX. Old stable 2.12 is compatible with Wizard, so you can apply boundary conditions using GUI. Latest version with new functions from Guido Dhondt and i8 versions for large models and limited RAM.
5. This version is tested with caelinux2017-2018. When you're installing it, please disconnect network and turn off updates (read www.caelinux.com for details). For Ubuntu 18 you have to install xterm:

Please Log in or Create an account to join the conversation.

More
6 months 5 days ago #9426 by Simulant
Replied by Simulant on topic CAELinux 2018 finally released.
Hi Joel,
thany for 2018 version. but for me it is not working yet.

i wanted to install it on a virtual machine using vmware player 15 .. installer crashed there.. oso i tried it on bare metal on two different machines Dell T5400 (bios 240gb SSD) and on a msiboard with 1225 V3 xeon with 120gb same behavior.. at first boot after install there was a initramfs error.. it think some uuid issue.. but i did not do any further tests..

i used multibootusb do make a bootable iso.. it seems to boot correctly..

Please Log in or Create an account to join the conversation.

Moderators: catux
Time to create page: 0.102 seconds
Powered by Kunena Forum